Darss Weststrand
 ___    _        _ _   _           _                   ___       
| __| _(_)___ __| | | /_\  _ _  __| |_ _ ___ __ _ ___ |   \ ___ 
| _| '_| / -_) _` | |/ _ \| ' \/ _` | '_/ -_) _` (_-<_| |) / -_)
|_||_| |_\___\__,_|_/_/ \_\_||_\__,_|_| \___\__,_/__(_)___/\___|
- Home - Videos - Gästebuch - Intern -


r Home
u Linux
  us Inst. n505x
  rs Inst. W3N
  rs Configfiles
  rs Screenshots
  rs Laptop-HD
r Gästebuch
r Kontakt
r Videos
r Admin








  Valid XHTML 1.0
Linux    Installation von Suse 7.3 + 9.1 auf Sony VAIO



Technische Daten

www.vaio-link.com/specifications/specifications.asp?l=de&m=135





Suse 9.1


Grundsystem installieren

CD-Laufwerk anschließen und die erste CD einlegen.
"Manuellen Modus" auswählen.
Bootoption: "ide2=0x180,0x386" ggf acpi=off (bin mir nicht sicher, ob es einen Unterschied macht).
Mit F2 und F4 Auflösung (1024*768) und Sprache einstellen.

Bei Softwareinstallation "minimale grafische (ohne KDE)" auswählen, damit nur von der CD 1 installiert wird, da Suse sonst das Laufwerk nicht mehr erkennt.
Softwareinstallation starten.
Dann wird der Rechner neu gestartet. Dabei CD-Laufwerk entfernen und gegen eine Netzwerkkarte austauschen, damit diese eingerichtet werden kann.
Wenn das Laufwerk eingesteckt bleibt, kann Yast nicht mehr weiterinstallieren und bleibt hängen :-(

Hardware wurde gut erkannt, habe aber noch nicht alles getestet.

Wenn das Grundsystem fertig installiert ist, kann natürlich zusätzliche Software KDE, Gnome, OO ... installiert werden.



Problem mit Save to Disk


Nach "Save to Disk" (Fn + F12) ging USB nicht mehr.

Hierfür muss ein Eintrag in der Datei "/etc/sysconfig/powersave/common" angepasst werden.

alt: POWERSAVE_UNLOAD_MODULES_BEFORE_SUSPEND="ohci_hcd ehci_hcd raw1394 ohci1394 ieee1394 bcm4400 ipw2100"


neu: POWERSAVE_UNLOAD_MODULES_BEFORE_SUSPEND="uhci_hcd ohci_hcd ehci_hcd raw1394 ohci1394 ieee1394 bcm4400 ipw2100"






Suse 7.3


Festplatte für Installation vorbereiten

Wenn neben Linux auch noch Windows auf dem Rechner betrieben werden soll,
muss vor der Linuxinstallation eine Partition (1,5 bis 2GB) für Windows angelegt werden.

Auf diese Partition kann jetzt mit Hilfe der Recovery-CD "Windows 98 SE" installiert werden.

Nach Windows kommt jetzt Linux an die Reihe.

Damit "Save to Disk" richtigt funktioniert, ist eine "kleine" Windowsinstallation nötig :-(


Grundsystem installieren

USB-Floppy und CD-Laufwerk anschließen und die erste CD einlegen.
Beim Bootvorgang muss man "linux ide2=0x180, 0x386" eintragen und mit der
F5-Taste die 1024er-Auflösung wählen. ->ENTER<-
... Hardware wird erkannt ...

Danach wird die Sprache, Zeitzone und Installationsart ausgewählt.
Jetzt folgt die Partitionierung (selbsterklärend).
Bei "Software" habe ich Standard mit Office und die erweiterte Auwahl gewählt.
Nur noch das ROOT Passwort vergeben und schon fängt das CD wechseln an.


Hardware einstellen


Monitor auswählen: "LCD 1024*768" --> Konfig speichern --> Installation abschließen

... neu booten ...

USB-Floppy und CD-Laufwerk ausbauen, Netzwerkkarte einbauen --> booten

KDE starten -> "Yast2" starten


Netzwerk: Netzwerk/Basis -> PCMCIA ankreuzen und ggf IP-Adresse und Gateway angeben.


Sound: Hardware -> Sound -> YMF 744B (DS-1S Audio Controller) wird erkannt
-> normales Setup -> Lautstärke anpassen und testen


ISDN (hier AVM Fritz Card PCMCIA): -> Yast2 Netzwerk/Basis -> Konfiguration von ISDN
-> AVM Fritz!PCMCIA und Euro-ISDN auswählen -> Internetzugan auswählen/ergänzen
-> Activate Firewall ...


Modem (hier Typhoon FAX/MODEM PC-CARD 56K): -> Yast2 Netzwerk/Basis
-> Konfiguration des Modems -> Tonwahl -> Lautsprecher ...
-> Internetzugan auswählen/ergänzen -> Activate Firewall ...


USB-Floppy wurde automatisch erkannt


Infrarot noch nicht getestet


iLink (IEEE 1394) noch nicht getestet


USB-Maus: entweder über XFree86 oder mit Editor.

Mit Editor in der Datei /etc/X11/XF86Config folgende Zeilen nach dem ersten Input Device ergänzen:

Section "InputDevice"
Driver"mouse"
Identifier "Mouse[3]"
Option "Device" "/dev/input/mice"
Option "InputFashion" "Mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


X-Server neu starten


Handspring Visor per USB

Vorsicht Bug!

1. als root den usbserial Treiber umbenennen.

/lib/modules/2.4.10-4GB/kernel/drivers/usb/serial # cp usbserial.o usb-serial.o

2. als root Devices erstellen, Rechte vergeben und linken

mknod /dev/ttyUSB0 c 188 0
mknod /dev/ttyUSB1 c 188 1
chmod 666 /dev/ttyUSB*
cd /dev
ln -s /dev/ttyUSB1 pilot
ln -s /dev/ttyUSB1 palm


Backup erstellen
pilot-xfer -p /dev/pilot -u /home/meinusername/palm-backup


Backup einspielen
pilot-xfer -p /dev/pilot -r /home/meinusername/palm-backup



Save to Disk

"einschlafen": Fn-Taste + F12-Taste
"aufwecken": Einschalter

Nach dem "aufwecken" einfach Maus aus- und einstecken und schon geht sie wieder ;-)


Sondertasten

Standby: Fn+Esc (kann Probleme mit USB geben)
Lautsprecher: Fn+F3 -> "aus" Fn+SHIFT+F3 -> "ein"
Lautstärke: Fn+F4 -> "lauter" Fn+SHIFT+F4 -> "leiser"
Helligkeit: Fn+F5 -> "heller" Fn+SHIFT+F5 -> "dunkler"
LCD/VGA: Fn+F7
Save to Disk: Fn+F12




TuxMobil - Linux on Laptops, PDAs and mobile Phones




























Abfragedauer 0.0113470554352 Sekunden